Mise à jour Paquet ECW pour Ubuntu

Suite à mon post (Cliquez ici pour plus de détails) sur l'ECW et Ubuntu, je mets à jour les paquets pour Ubuntu Lucid Lynx 10.04 qui est basé sur Debian Squeeze.

Pour que ce soit effectif, dans un terminal, copier coller ceci :
1) Ajout des dépôts et installation des prérequis
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable/ubuntu #On ajoute le dépôt
sudo apt-get update && sudo apt-get upgrade #On recharge et on met à jour la liste des paquets
sudo apt-get install gdal-bin libgdal-ecw-src #On installe gdal et le paquet libgdal-ecw-src





2) Maintenant vous pouvez installer les paquets en fonction de votre architecture :
Pour Ubuntu 64bits :

libecwj2_3.3-1_amd64.deb : http://www.mediafire.com/?lr8yu653768z91u

libgdal-ecw_1.7.2-1_amd64.deb : http://www.mediafire.com/?8xj1fyy6m58na69




Pour Ubuntu 32bits :

libecwj2_3.3-1_i386.deb : http://www.mediafire.com/?yvrmmzh0xmc

puis dans un terminal :
sudo gdal-ecw-build /usr
Je n'ai pas eu le temps de créer de paquets pour les version 32bits

3) Enfin pour vérifier l'installation :

gdalinfo --formats | grep ECW

Deux formats supplémentaires devraient apparaître :
ECW (rw): ERMapper Compressed Wavelets
JP2ECW (rw+): ERMapper JPEG2000

J'espère que ça aidera du monde et n'hésitez pas à poster vos commentaires

Commentaires

  1. De rien ! Content que ça puisse servir ...

    RépondreSupprimer
  2. Pourquoi ?
    gdalinfo --formats | grep ECW
    ERROR 1: libNCSEcw.so.0: cannot open shared object file: No such file or directory
    ERROR 1: libNCSEcw.so.0: cannot open shared object file: No such file or directory

    RépondreSupprimer
  3. gdalinfo --formats | grep ECW

    ERROR 1: libNCSEcw.so.0: cannot open shared object file: No such file or directory
    ERROR 1: libNCSEcw.so.0: cannot open shared object file: No such file or directory
    Pourquoi ?

    RépondreSupprimer
  4. Vous devriez faire un sudo ldconfig puis retaper la commande

    RépondreSupprimer
  5. Je te remercie
    gdalinfo --formats | grep ECW
    ECW (rw): ERDAS Compressed Wavelets (SDK 3.x)
    JP2ECW (rw+): ERDAS JPEG2000 (SDK 3.x)
    dans le terminal c'est OK, par contre Qgis mode raster ECW ne fonctionne pas.

    RépondreSupprimer
  6. Bonjour,
    Comment utiliser l'application API géoportail pour sig dans quantum gis avec linux ubuntu ?
    https://api.ign.fr/geoportail/document.do?doc=6593219
    cordialement,
    Rems

    RépondreSupprimer
  7. ça marche, merci!
    Silvio

    RépondreSupprimer
    Réponses
    1. Bonsoir,
      j'ai fait toute la manip. et je n'ai aucune réponse lorsque j'envoie dans le terminal : gdalinfo --formats | grep ECW
      Je précise que je suis sous lucid, que j'ai la version 1.7.4 de QGIS et que je n'arrive toujours pas à ouvrir les ecw.
      Merci d'avance pour la réponse.

      Supprimer
  8. C'est fait et il n'y a aucun changement, toujours le message : "source de données non gérée".

    RépondreSupprimer
  9. Il faut refaire depuis le début :

    Installation du paquet fournit libecwj2_3.3-1 puis ajout du ppa ubuntu ubuntugis puis
    installation via apt ou synaptic de ligdal-ecw-src
    Puis lancer la commande sudo gdal-ecw-build /usr
    puis sudo ldconfig.

    Bien respecter l'architecture, cependant je n'ai testé qu'en 64bits ....

    RépondreSupprimer
  10. Bonjour,
    j'ai bien tous les paquets installés (vérifié dans synaptic) et la commande gdalinfo --formats | grep ECW me renvoie maintenant :
    ECW (rw): ERDAS Compressed Wavelets (SDK 3.x)
    JP2ECW (rw+v): ERDAS JPEG2000 (SDK 3.x)
    En revanche, toujours pas possible d'ouvrir les ecw.
    Je suis bien en 64 bits.

    RépondreSupprimer
  11. Si c'est affiché, vous pouvez les lire avec gdal.
    JE me répète, à présent pour qgis :
    sudo ldconfig ... puis relancer qgis

    RépondreSupprimer
    Réponses
    1. Oui, c'est affiché dans le terminal, j'ai bien fait 10 x le sudo ldconfig et pourtant mes ecw ne s'ouvrent pas ( "ce n'est pas une source de données raster gérée").
      Je vous remercie du temps que vous m'avez conascré mais je sens votre impatience, j'ai pourtant fait toute la procédure.
      Mes dalles ecw sont des orthophoto de l'ign.

      Supprimer
  12. Bonjour, lorsque j'exécute cette commande : sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable/ubuntu

    J'ai cette réponse : Impossible d'accéder au PPA (https://launchpad.net/api/1.0/~ubuntugis/+archive/ubuntugis-unstable/ubuntu) pour récupérer les informations du PPA, veuillez vérifier votre connexion internet.

    Pourtant je n'ai pas de problème de connexion.

    Que dois je faire? (je débute avec ubuntu)

    En vous remerciant par avance.

    RépondreSupprimer
    Réponses
    1. Refaire mais avec cette commande :
      sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

      Supprimer
  13. Merci cela fonctionne,

    Toutefois lors de l'installation des paquets
    cela m'affiche : commande introuvable...

    J'ai donc cliqué sur le lien et téléchargé les fichiers mais après...je ne sais pas quoi faire.

    Désolé mais je suis complètement perdu.

    Merci d'avance

    RépondreSupprimer
    Réponses
    1. Bon il y a du nouveau,

      J'ai :
      ECW (rw): ERDAS Compressed Wavelets (SDK 3.x)
      JP2ECW (rw+v): ERDAS JPEG2000 (SDK 3.x)

      quand j’exécute : gdalinfo --formats | grep ECW

      Par contre quand je fais sudo ldconfig et que je rentre mon mot de passe il ne se passe rien dans le terminal.

      En redémarrant Qgis toujours un bug au moment d'ouvrir les ECW.

      D'après vous qu'est ce que j'ai mal réalisé?

      Merci de votre aide

      Supprimer
    2. La compilation de la lib ecw n'est pas bonne !
      Si vous voulez une version plus à jour, il faut désinstaller l'ancienne via synaptic par exemple si vous n'êtes pas familier avec la ligne de commande et reinstaller la nouvelle ici : http://www.mediafire.com/?gi82xagr7wdq31o
      64 bits uniquement j'ai compilé en 32bits mais pas uploadé encore !

      Puis refaire cette commande (compilation de la lib gdal pour l'ecw) :
      sudo gdal-ecw-build /usr

      Supprimer

Enregistrer un commentaire

Posts les plus consultés de ce blog

Disposer du support de l'ECW sous Ubuntu

Install GDAL ECW Support in Archlinux / Manjaro

L'ECW sous MacOSX : comment le rendre fonctionnel